Analytics Outage
Resolved·Partial outage

This has been resolved as AWS services have come back online that support our 3rd party analytics integration.

Tue, Oct 21, 2025, 12:22 AM
(2 weeks ago)
·
Affected components
Analytics
Updates

Resolved

This has been resolved as AWS services have come back online that support our 3rd party analytics integration.

Tue, Oct 21, 2025, 12:22 AM

Monitoring

Saleo's embedded analytics vendor, Explo, is still recovering from the global AWS outage this morning.

Mon, Oct 20, 2025, 05:45 AM(18 hours earlier)